这个问题我结合了Claude的解决办法:

这个错误表示conda 在加载conda-libmamba-solver时找不到libarchive.so.19这个共享库文件。

这可能是因为:

libarchive版本不匹配,conda-libmamba-solver依赖的libarchive版本高于当前系统中的版本。

libarchive共享库文件没有正确安装或目录结构失配。

conda环境中的依赖关系错误,导致找不到对应的库文件。

解决方法:

通过conda list查看libarchive版本,确保与conda-libmamba-solver依赖版本匹配。如果不匹配考虑重新安装libarchive。

查看/usr/lib或/usr/local/lib等路径下是否真的存在libarchive.so.19文件。如果不存在考虑重新安装libarchive。

重新创建conda环境,清理可能残留的错误依赖。

升级conda和依赖版本到最新。

使用ldd工具在conda环境中查看conda-libmamba-solver是否缺少依赖库。

编译安装conda时是否缺少依赖库导致问题。考虑重新编译安装conda。

使用conda update --all更新所有包试试。

尝试切换conda版本或使用装在其他位置的conda环境。

通过上述方法排查依赖和版本问题通常可以解决这个错误。如果还不行考虑重新编译安装conda

以上是Claude的解决。

关于我最终解决:

使用conda list我查看到我是安装有libarchive的,所以没有缺少。

使用sudo find / -name 'libarchive.so.*' 2>/dev/nullw我查看到路径下存在libarchive.so文件

这个时候我们需要sudo ln -s /usr/lib64/libarchive.so /usr/lib64/libarchive.so.19

这个操作具体参考联手ChatGPT解决使用conda命令出现的conda-libmamba-solver和load_entrypoints报错问题 - 知乎 (zhihu.com)

此时再sudo find / -name 'libarchive.so.*' 2>/dev/nullw会发现路径下多了一个libarchive.so.19

但是继续随便使用conda的命令还是会出现报错。

后来我继续解决,最终使用conda update -n base -c defaults conda这个命令直接更新了依赖包,

这个命令的意思是:在默认渠道中更新 conda 包管理器在 base 环境中的版本。运行该命令会检查 conda 包管理器是否有可用的更新版本,并将其安装到指定的环境中。此时会出现以下,直接y.

这样之后我的问题就已经解决了,再使用conda 的其他命令就再也没有报错。

相关文章

评论可见,请评论后查看内容,谢谢!!!
 您阅读本篇文章共花了: 


大家都在找:

linux:删除文件夹linux命令

conda:conda翻译