iOS 报错“Xcode Command PhaseScriptExecution failed with a nonzero exit code” 解决方案

xcode编译报错

"Xcode Command PhaseScriptExecution failed with a nonzero exit code"

问题:xcode版本差异造成的不兼容。低版本xcode不兼容高版本xcode。

解决方案1:

在Xcode菜单栏选择File -> Workspace Setting -> Build System 选择Legacy Build System 重新运行

解决方案2:

将低版本xcode升级为最新版本,这样就可以兼容了。

ps:如果高版本xcode提交的代码不重要,也可以回滚到低版本xcode提交的代码阶段。这个方法只是试用不重要的且紧急的时候。

参考链接

评论可见,请评论后查看内容,谢谢!!!
 您阅读本篇文章共花了: