昨天使用vscode连接服务器还好好的,今天突然连不上了,查遍全网没发现一个靠谱的方案

查看日志发现一堆Waiting for server log...

还显示

Warning: Missing GLIBCXX >= 3.4.25! from /usr/lib/x86_64-linux-gnu/libstdc++.so.6.0.22

Warning: Missing GLIBC >= 2.28! from /lib/x86_64-linux-gnu/libc-2.24.so

Error: Missing required dependencies. Please refer to our FAQ https://aka.ms/vscode-remote/faq/old-linux for additional$

发现是新版本Vscode对平台上旧版的GLIBCXX和GLIBC不支持了,遇到问题的似乎不是一个人:

https://github.com/microsoft/vscode/issues/203967

打开Vscode,Ctrl+Shift+P,输入:Help: About,查看当前Vscode版本信息,可以看到当前版本已是最新的,因为Vscode是默认自动更新的,所以如果没有服务器root权限只能回退Vscode版本。

解决办法

1. 安装旧版本,例如85:https://code.visualstudio.com/updates/v1_85,注意在这里下载,不要点右上角新版本的

2. 安装后成功连接!

3. 关闭Vscode自动更新

Vscode默认是自动更新的,所以需要手动关闭防止再次出bug:

VScode 关闭自动更新方式_vscode git update.mode-CSDN博客

精彩文章

评论可见,请评论后查看内容,谢谢!!!
 您阅读本篇文章共花了: