使用:mybatis-generator:generate命令生成时提示:

        原因是所使用的maven仓库中没有我们需要的 org.eclipse.m2e

解决方法:

        如果是windows系统,需要先安装git软件,然后执行下边的命令:

git clone https://github.com/mfriedenhagen/dummy-lifecycle-mapping-plugin.git

cd dummy-lifecycle-mapping-plugin/

mvn -Dmaven.test.skip -U clean install

     git软件下载地址:

https://softdl.360tpcdn.com/auto/20190218/104714032_5267868db9e9939d8ac6f5181669adf9.exehttps://softdl.360tpcdn.com/auto/20190218/104714032_5267868db9e9939d8ac6f5181669adf9.exe        这个快一些,选择普通下载,安装的时候调整安装路径,之后一路next,最后finish。

        如果时间充裕,可以在官网上下载 (慢一些)Githttps://git-scm.com/

        添加至本地maven仓库 

        win+R,打开cmd,依次输入一下三个命令

git clone https://github.com/mfriedenhagen/dummy-lifecycle-mapping-plugin.git

cd dummy-lifecycle-mapping-plugin/

mvn -Dmaven.test.skip -U clean install

 

 

精彩链接

评论可见,请评论后查看内容,谢谢!!!
 您阅读本篇文章共花了: