解决 Could not determine java version from '11.0.8'. 问题 , 有两种方案 ,

方案一 : Android Studio 降级 , 使用历史版本的 Android Studio 环境 ;方案二 : 提升 Gradle 版本 ;

打开一个比较老的项目 , 错误信息 :

Could not determine java version from '11.0.8'.

选择 " 菜单栏 / File / Project Structure " 选项 ,

查看该 Android 工程的 Android Gradle 插件版本是 3.2.0 , Gradle 版本是 4.6 , 这是几年前使用的版本了 , 目前使用最新的 Android Studio 是无法编译该工程的 ;

解决方案

选择 " 菜单栏 / File / Project Structure " 选项 ,

在弹出的 Project Structure 对话框中 , 将 Android Gradle 插件版本更新为 4.2.1 , 将 Gradle 插件版本更新为 6.7.1 ;

精彩文章

评论可见,请评论后查看内容,谢谢!!!
 您阅读本篇文章共花了: