文章目录

1、前期准备2、证书&签名3、编码&发布FQA:问题1:The graphic card OpenGL version is too old for Previewer to work. It must be 3.2 or later. Update the OpenGL driver based on the graphics card model.问题2:编译成HAp,报错 entry "key" does not contain a key问题3:安装hap报错了:配置文件格式失败

背景:

在鸿蒙系统的加持下,华为手表的智能化明显得到大幅的提升。华为智能手表2022年在国内的市场份额也是处于top3的地位,不过离第一名苹果还是有些距离,作为华为忠实用户的我智能生态必须搞起。

1、前期准备

手表设备:

华为watchgt3(目前鸿蒙版本是2.1.XX)

补充:watch系列是可穿戴设备属于 wearable,而GT系列是轻可穿戴设备也就是lite wearable

手机:

Magic4 (新荣耀)

开发IDE:

devEco3.0.0.800

2、证书&签名

准备证书文件夹 获取uuid(手机链接手表,应用市场下载应用调试助手复制UDID) 进入华为开发者网站完成认证 添加设备:用户与访问 - 左侧导航栏的设备管理 - 右上位置的添加设备 并填写相关信息然后点击提交 新建项目:我的项目-添加项目,随便填写项目名称后点击`完成 新建本地项目(gt的话记得是选择[Lite]Empty Ability) 获取、添加证书(记得p12的keyAlias前后保持一致) 编译调试

具体参见链接:

https://sianx.com/posts/8909d2af/

3、编码&发布

1、代码开发,模拟图如下

2、编译生成hap文件,build -》 build hap

3、手机连接到电脑,将编译生成的hap文件拷贝到手机的/haps目录下

4、在调试助手上面点击安装,然后手表应用就会多一个这个图标,done!

补充:

gt系列没有开发者模式,相比之下数字系列调测更加简单,可以点击手表的版本7次就可以进入开发者模式,然后在DevEco 的Tool中的IP connect链接就行了,

参考:https://sianx.com/posts/8909d2af/

FQA:

问题1:The graphic card OpenGL version is too old for Previewer to work. It must be 3.2 or later. Update the OpenGL driver based on the graphics card model.

一开始是使用Empty Ability, 后面使用了[Lite]Empty Albility就没有这个问题了

问题2:编译成HAp,报错 entry “key” does not contain a key

说明之前填的keyAlias对不上,前后不一致,后面重新弄一遍就可以了

问题3:安装hap报错了:配置文件格式失败

查看华为开发者社区的讨论结果,换用devEco3.0.0.800版本就行了

(以上为DreamKite本人原创,转载请附上原文链接)

相关链接

评论可见,请评论后查看内容,谢谢!!!
 您阅读本篇文章共花了: