QT12.12是博主自用最多的一个版本,所以选用这个版本作为演示。有一点需要说明到2023年11月以来整个QT5版本里面,QT5.15版本是唯一需要在线更新的版本,也就是官方找不到离线安装包,QT15是中文界面其UI也做出了改变,而QT6也是新出的版本存在一定的兼容性,广大学子如果学习的其他博主的文档或者视频时最好跟着配套的版本安装不一定跟着博主。

文章最开始是准备使用QT5.15演示的,但是发现5.15也成在线安装的了,QT5.13又没有过就用QT5.12了,文中有个报错使用的就是在线的版本,但是依赖已经安装了,没有更新的截图,所以版本问题不要纠结,跟着文章走就是了。而且在线和离线安装包安装的步骤大致相同,只不过在线的相较于旧版改变了UI和使用了中文安装界面,关于在线安装的步骤指挥指出一些不同,不会讲太多。

目录

一、获取安装包、

(一)官方网址获取安装包

(二)使用系统指令wget获取安装包

二、旧版离线版QT安装(旧版QT5.15之前)

(一)给文件分配执行权限

1、图形界面操作:

 2、终端操作:

(二)运行.run文件,开始安装

1、欢迎界面为账号i登录界面,有账号登陆后直接下一步,没有的点击sign up注册一个!

2、 这里直接两个方框打勾跳过就行了,就是同意他们公司的条规的!

3、 指定安装目录的,ubuntu里面我很多设置都是用的默认的,如果你有指定的位置修改一下就行!

4、 根据需求选好开发工具就行了,我这里不会有android开发所以全部插掉了,其他的都选了!

5、 也是同意条款的,打勾下一步!

6、 再后面一直下一步到这个界面等待安装完成就行了!需要注意的是,如果你是选择的5.15以上版本的安装如果遇到错误就得使用一下魔法,我以前用的联通网可以直接下,但是现在移动得开魔法。

7、之后能在左下角抽屉里面找到该程序就代表安装成功了!

三、新版在线安装(新版QT5.13以上版本)

 (一)新版里面增加了一个获得用户的bug信息,完善软件。这个可以选第一个,毕竟没解决一个bug我们使用体验会更好,类似于为开源作贡献嘛!

(二)新版在线安装目录里面添加了可选项,这里直接选择第一个自定义

(三)新版需要安装的工具选择界面里面改动很大。

四、配置环境变量

五、设置QT中可中文输入

(一)添加IBUS配置,打开bashrc

(二)在打开的文件中添加

一、获取安装包、

安装包获取途径博主知道的有两种,一是从官方网址获取,二是通过系统指令获取,以下是操作步骤:

(一)官方网址获取安装包

下载地址为用户浏览器指定的下载地址              

网址:Index of /official_releases/online_installersIndex of /archive/qt/5.12/5.12.12https://download.qt.io/archive/qt/5.12/5.12.12/Index of /official_releases/online_installers

选择qt-opensource-linux-x64-5.12.12.run点击下载

(二)使用系统指令wget获取安装包

直接复制下面代码到ubuntu终端中运行,其中wget后面的链接是我们要下载的文件的地址,如果出问题,自己将需要下载的文件链接在复制修改以下就行了。

再就是有读者觉得这有点脱裤子放屁了,但是在无图形界面很多文件下载是需要使用这些系统指令下载文件和安装的,所有建议刚开始学习的读者多使用系统指令操作,虽说图形界面带来许多便利,但是还是少依赖对图形界面的依赖。

sudo wget xxx文件

sudo wget https://download.qt.io/archive/qt/5.12/5.12.12/qt-opensource-linux-x64-5.12.12.run

补充一下:

如果是24k纯新手的话,你就直接在桌面打开终端输入上面的指令可以直接下载到桌面。之后就顺着操作就行了。

二、旧版离线版QT安装(旧版QT5.15之前)

(一)给文件分配执行权限

许多下载的可执行文件默认都是只读的状态,系统只能读取文件中但是不能对文件进行操作,所以我们得将文件修改成可执行文件。下面给出了两种方法:

1、图形界面操作:

在ubuntu中的文件管理器里找到你下载的文件,一般都在下载栏里面。直接右键->属性->权限里面把“允许执行文件”勾上,把只读的下拉框改成读写。

 2、终端操作:

如果是按照上面的步骤直接在桌面操作的可以直接使用下面的指令,如果是在其他位置操作的需要使用cd指令转到安装包位置,然后在终端运行下面指令:

终端给予文件可执行权限需要用到chmod指令:

格式:chmod a+x 文件名

chmod a+x qt-opensource-linux-x64-5.12.12.run

(二)运行.run文件,开始安装

由于我使用的新装的系统,缺少关于安装依赖的库,如果出现和我一样的错误就需要安装了,报错和解决办法如下图。

报错:

解决办法:

sudo apt install --reinstall libxcb-xinerama0

解决以后就可以使用./正常安装文件了。

1、欢迎界面为账号i登录界面,有账号登陆后直接下一步,没有的点击sign up注册一个!

2、 这里直接两个方框打勾跳过就行了,就是同意他们公司的条规的!

3、 指定安装目录的,ubuntu里面我很多设置都是用的默认的,如果你有指定的位置修改一下就行!

4、 根据需求选好开发工具就行了,我这里不会有android开发所以全部插掉了,其他的都选了!

5、 也是同意条款的,打勾下一步!

6、 再后面一直下一步到这个界面等待安装完成就行了!需要注意的是,如果你是选择的5.15以上版本的安装如果遇到错误就得使用一下魔法,我以前用的联通网可以直接下,但是现在移动得开魔法。

7、之后能在左下角抽屉里面找到该程序就代表安装成功了!

三、新版在线安装(新版QT5.13以上版本)

在线版本许多安装步骤和旧版大同小异,这里只例举两者一些不同:

 (一)新版里面增加了一个获得用户的bug信息,完善软件。这个可以选第一个,毕竟没解决一个bug我们使用体验会更好,类似于为开源作贡献嘛!

(二)新版在线安装目录里面添加了可选项,这里直接选择第一个自定义

(三)新版需要安装的工具选择界面里面改动很大。

QT Design Studio不说复杂了就是开发UI使用的,这里第一个4.3.1我实际是没有勾的,个人还是喜欢长更新的,所以使用了LTS版本的。

而下面的QT就是整个QT开发的核心部件了,还是除了安卓,其他全选。这个还是按照个人需求吧!

四、配置环境变量

找到自己安装QT的目录,按照我下面的目录结构找到相应的位置修改一下,注意别套我的,我们安装路径可能不相同

打开etc/profile文件添加以下信息

export PATH=/home/xiaochenggk/Qt5.12.12/5.12.12/gcc_64/bin:$PATH

export PATH=/xiaochenggk/Qt5.12.12/Tools/QtCreator/bin:$PATH

五、设置QT中可中文输入

以前在ubuntu上面使用QT是无法输入中文的,需要配置一下才能输入中文。但是这次安装的QT确是可以,但为了以防万一我还是加上这部分的内容,如果有小伙伴在安装完QT以后打开新建一个项目看看是否能输入中文。可以输入了,那么你可以直接走了,不能输入的接着下面的教程继续设置。以下是我以前赵的一个解决方案,但是我只在系统自带输入法中使用过。

(一)添加IBUS配置,打开bashrc

vim ~/.bashrc

(二)在打开的文件中添加  

export XMODIFIERS="@im=missing"

export GTK_IM_MODULE=fcitx

export QT_IM_MODULE=IBus

export IBus &

export LC_CTYPE=zh_CN.utf-8

相关链接

评论可见,请评论后查看内容,谢谢!!!
 您阅读本篇文章共花了: